Supported Mac OS versions

Pixellu SmartAlbums 2020 supports Mac OS 10.14 (Mojave) or higher.

Still need help? Contact Us Contact Us